Results 1 to 4 of 4

Thread: Set at 250 only hits 205.

  1. #1

    Default Set at 250 only hits 205.

    I have enjoyed this forum for two years, which is when i purchased my 1400. I use the 1400 about once a month. I have been concerned for some time that my 1400 wasn't getting hot enough. Yesterday i smoked some salmon and chicken (one whole and 6 breasts). I set the temperature to 250 and monitored with a dual maverick probe. After 8 hours the dark meat on the chicken hit 172 degrees. The internal temperature of the box never got above 206. The outside temperature was 65 degrees for most of the day.

    Question: does this sound normal, or does it sound like i have a faulty thermostat?

    Ps. The chicken was great. It just took much longer than expected.

    Thx in advance.

  2. #2
    Join Date
    Aug 2010
    Location
    Plano, Texas
    Posts
    598

    Default

    Cpbbq,

    This does not sound normal. Give SmokinTex a call to discuss.
    Remember: If it weren't for marriage, men would go through life thinking they had no faults at all

  3. #3

    Default

    Thanks DRReeves, sure enough I replaced the thermostat. The unit is now running as it should. The kind folks at Smokin Tex were kind enough to send the unit. It took me about an hour start to finish. If i had to do it again it would only take 15 minutes now that I know what I am doing.

    Scott, et all at Smokin Tex.... Great Customer Service. Thumbs up!!

  4. #4
    Join Date
    Aug 2010
    Location
    Plano, Texas
    Posts
    598

    Default

    Cpbbq,

    Could not agree more on the customer service! I love being treated as if I were part of the family!

    Good to hear you are back up and running.

    Enjoy!!!
    Remember: If it weren't for marriage, men would go through life thinking they had no faults at all

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •